
 

FLASH 8 STEP BY STEP 
 
Directions: The following is a guided tutorial. The teacher is meant to deliver each of the steps verbally, while 
students perform the task on their computers using Flash. You may choose to project this page (or create an 
overhead copy to be used on an overhead projector) onto a screen so that your class can see the screen shots below 
and identify that they are progressing accurately through each step of this tutorial. We recommend that you give 
the students a copy of the Step by Step, as it will greatly assist in their note-taking and provide them with 
“how to” reference material for their class project. Students should also be taking notes on the process so that 
when they come back to the lab for future Flash lessons, the teacher does not have to repeat information already 
given here. The students would be responsible for referencing their notes, if they forget how to use a tool. 
 
Content 

Learn how to use the Push Button Component • 
• 
• 

Scenes 
Use Buttons to move within a Flash Movie 

1. Start the Flash Program 
Double click on the icon on your computer’s desktop, or 
From the Start Menu select Programs, then select Macromedia Flash MX and click on the submenu Flash MX. 
 
Open the file you were working on for the previous lesson. File > Open. 

2. Hide the Existing Layers 
Click on the “Eye” column to Hide all the existing Layers. (A red X should appear in the column for all Layers.)  
For this exercise the work already done won’t be used. 

3. Insert a New Layer 
Insert > Layer. Name it “Push Button”. 

4. Flash UI Components 
We are going to learn one of the Flash UI Components that come with the program. Flash provides a number of pre-
built components that can be used in presentations. They are available from the Window > Components window. 
 
Click on Window > Components to see what’s available. 
 
There is a Check Box, List Box, Radio Button, Scroll Pane, Combo Box, Push Button and Scroll Bar. The Scroll 
Pane is for Scrolling text and pictures. The other elements you have seen in many software programs and on the 
web. Each of the Components is described in the Help. 
 
We are going to use the Push Button Component. Push Buttons are a quick way to create Buttons, but they do not 
allow for all the different customization options you may want, which is why we learned how to create our own 
Buttons in a previous lesson. 

5. Creating a Push Button 
Click on the Push Button Component and drag it onto the Stage. 
 
Notice, in the Properties Window in the upper right corner are two tabs: Properties and Parameters. 
Click on the Parameters tab. In the center there are two Parameters: Label is the text that will show on the top of the 
button. The original value of the Label is the text “Push Button”. Change it to “American Dialect Society”. 
 
Notice that the text is larger than the Push Button. Right click on the Push Button on the Stage. Select Scale. Using 
the outline adjust the shape of the Push Button so the full text is visible. The text will not wrap around when it 
reaches the end of the Push Button Component. 
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On the left of the Properties Window give the Push Button an Instance Name: “ADS”, for American Dialect Society. 
It is always a good practice to give every object in your Flash movie a clear, meaningful and relevant name. It will 
help you distinguish the objects from each other. 

6. Color the Button 
On the Properties tab is the same Color choices that all Symbols have and we have already learned. Pick Tint and 
select a Tint color and set the Tint Percentage to 50%. 

7. Going to a Web Page 
The Push Button Component is a Movie Clip, so its Action Script behavior is slightly different than the Button we 
made previously. 
 
Click on the Push Button on the Stage, and then go to the Actions Window and confirm that the drop down list on 
the top says “Actions for ADS (Push Button)”. Namely that the Actions will be associated with your Push Button. 
 
Select Actions, Movie Control, double click on “on”. Make sure the “Release” check box is checked. Then, in the 
Actions Window, click on Actions, then Browser/Network, and then double click on GetURL. This is the same 
command that we used for our previous button. The Parameters for the GetURL show up in the center of the Actions 
Window. Remember to fill in the full “ http://www.americandialect.org” web address. For Window, again select 
“_blank” to have it pop up in a new browser window. Set Variables to “Don’t Send”. 

8. Test the Button 
Make sure that Control > Enable Simple Buttons is checked. 
Then use Control > Test Movie. 
Click on the Push Button and see that the American Dialect Society home page shows up in a new Browser window. 

9. Moving to a Different Part of the Flash Movie 
Sometimes you will want to give the User the option of jumping to a different part of your Flash movie. Perhaps, 
you have chapters in a book, or different subject areas or they might want to go back to the beginning, etc. Using a 
Button or Push Button is one way of doing this. (It is also possible to build menu systems, but that will not be 
discussed here. The Macromedia web site has technical notes that can get you started.) 
 
The most important thing is to plan the movement and the different sections out on paper BEFORE you start to work 
on Flash. Things you want to consider are which sections of Flash are motion graphics, which sections are static 
pages (i.e. no motion or changes), what will be the order that the User wants to move around, what makes sense 
from the needs of communicating your ideas and information, etc. 
 
For this example, we already have a motion graphics section, we will now add a single static page (i.e. a single 
frame) for the design credits. And, the buttons that move back and forth between the two sections. Each of these 
sections will be implemented as Scenes in Flash.  

10. Scenes 
In Flash, there is the possibility to section the Movie into different “Scenes”. These are analogous to chapters in a 
book. We will put the Credits in a different Scene, then the movie we have been creating, which by default was 
created in Scene 1. Scenes run consecutively, so we will have to add additional controls to stop and start the movie 
where we want. 
 
Insert > Scene. Open Window > Scene and in the Scene Panel on the right you will now see two Scenes listed. 
Scene 1 and Scene 2. Scene 1 is the default and original Scene where our artwork is stored. Scene 2 is where our 
credits will be listed. 
 
You can rename the Scenes in the Scene Window, if you wish. 
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11. Rename the Layer 
Rename the Layer in Scene 2 to “Credits”. 

12. Create the Credits Frame 
On the Stage create two text boxes. One that says “Credits” and another that lists your name. For the sake of the 
exercise keep the artwork simple. Obviously, you can make the Credits page as fancy as you wish.  
 
It is very important to give the Frame a Frame Label, such as “Start” – this being the first frame in the Scene (any 
name that is meaningful so that you know it refers to this Frame), in the Properties Window for the Frame. Frame 
numbers always change depending upon how you insert and delete frames. Frame Labels are a property of the 
Frame and don’t change even if the Frame is moved around. The Frame Label is used to reference this Frame in 
Action Script commands. (Click on the Frame in the Timeline to get the Properties window to change to the Frame 
properties.) 

13. Add the “Stop” 
We have to add a “stop” playing command, otherwise, the Scene will continue playing on to the next Scenes 
(presuming your movie has more Scenes and, thus, complexity, then this example.) 
 
In the Actions Window, make sure the drop list says “Actions for Frame 1 (Labeled Start) for Layer Named 
Credits”. Select Actions, Movie Control, double click on “stop”. 

14. Add the Start Movie Button 
We are going to use one of our existing Buttons (again to focus our lesson time on function, not art.) 
 
Drag the Button Symbol that we used for the Dialect button from Library onto the Stage. Give this Instance of the 
Button a Name in the lower left corner of the Properties box. (You may have to turn off Control > Enable Simple 
Buttons, so you can work with the Button as an object on the Stage and not have it take its defined action – like 
linking to the web site..) 
 
Select the Text Tool and create the text “Start Movie” on the Stage over the Button Symbol. Then use the Align 
Window to center the text over the Button. Use the Selection tool to drag a box around both the Button and the text, 
so the Align functions know which objects to Align together. Also, uncheck the “To Stage” option. 
 
In the Actions Window make sure the drop list at the top references this Button. Select Actions, Movie Control, 
double click on Goto. In the Scene parameter drop down list, select Scene 1, Type: Frame Number, Frame: Frame 1. 
(Because we are starting at the beginning we need not be concerned with Frame Labels, because from the Credits 
page, we want to go the beginning of the Scene with the movie. Frame 1 is always the beginning.) 

15. Insert the Credits Button 
Switch back to Scene 1. In the Scene Window, select Scene 1. 
 
On the Push Button Layer, in Frame 72. Click on this Frame in the Timeline and then press F6 or Insert > Keyframe. 
In order for actions to take place in just Frame 72 we need to have it be a Keyframe, so that it will have different 
behavior then the preceding frames. 
 
On the Push Button Layer, in Frame 72, drag the Button Symbol that we used for the Dialect button from Library 
onto the Stage. Give this Instance of the Button a Name in the lower left corner of the Properties box. (You may 
have to turn off Control > Enable Simple Buttons, so you can work with the Button as an object on the Stage and 
have it not do its action.) 
 
Select the Text Tool and create the text “Credits” and use the Align Window to center the text over the Button. Use 
the Selection tool to drag a box around both the Button and the text, so the Align functions know which objects to 
Align together. Also, uncheck the “To Stage” option. 
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In the Actions Window, make sure the drop down list says “Actions for Credits (Push Button)”. Select Actions, 
Movie Control, double click on “goto”. Notice the Parameters that show up in the Window. On the top, select “Go 
to and Stop”. This is because we want to show only the one Frame and not go any further showing any other Frames 
in the Flash movie. 
 
In the Scene parameter, select from the drop down list “Scene 2”. In the Type parameter, select “Frame Label”. This 
tells us that how we are identifying the Frame to Go to is by a Label Name. In the Frame parameter use the drop 
down list to select the Frame Label “Start”. 

16. Stop Action for the Frame 
We are going to add the stop command for this Scene, so that the Movie stops here and doesn’t continue on without 
the User requesting it. In Flash all Scenes run consecutively one after the other, unless you give specific instructions 
to do other actions, like Stop. 
 
In the Actions Window, select the “Actions for Frame 72 of Layer Named Push Button” from the drop down list. 
Select Actions, Movie Control, double click on “stop”. 

17. Test the Movie 
Save your work (you are doing that as you go along aren’t you?).  
 
Control > Test Movie.  

18. Publish the Movie 
First, set the Layers Graphic and Button to Hide (not shown). Although they are in the file, we don’t want to see 
them when we publish the Movie. As for this rendition, we only want to see the Transitions that we have created. 
 
Goto File > Publish Settings. Click on the HTML tab in the dialog box. Uncheck the Loop checkbox in the Playback 
section. This will have the Flash movie play just once straight through, rather than continuously loop around to the 
beginning. Press OK. 
 
Select File > Publish. 
 
On your directory, there will be 3 files with your file name.  
File_Name.fla which is the design file that you have been creating the Flash movie in. 
File_Name.swf which is the published Flash movie, that can played by a player, put on a web site, etc. 
File_Name.html which is an html template page that calls the Flash movie File_Name.swf. This is hear to help you 
embed Flash into your HTML. 
 
Double click on .swf file to see your movie as the user experiences it. Press the American Dialect Society and 
Credits buttons to test how they work. Make sure that all of your artwork and text is visible, that you didn’t 
inadvertently place something on top of something else that you didn’t mean to. 
 
Congratulations! You have created a movie with different sections and learned how to jump back and forth. 


