
 

FLASH 6 STEP BY STEP 
 
Directions: The following is a guided tutorial. The teacher is meant to deliver each of the steps verbally, while 
students perform the task on their computers using Flash. You may choose to project this page (or create an 
overhead copy to be used on an overhead projector) onto a screen so that your class can see the screen shots below 
and identify that they are progressing accurately through each step of this tutorial. We recommend that you give 
the students a copy of the Step by Step, as it will greatly assist in their note-taking and provide them with 
“how to” reference material for their class project. Students should also be taking notes on the process so that 
when they come back to the lab for future Flash lessons, the teacher does not have to repeat information already 
given here. The students would be responsible for referencing their notes, if they forget how to use a tool. 
 
Content 

• Learn how to create Button Symbols 
• Learn how to use Buttons to link to other web pages 

1. Start the Flash Program 
Double click on the icon on your computer’s desktop, or 
From the Start Menu select Programs, then select Macromedia Flash MX and click on the submenu Flash MX. 
 
Open the file you were working on for the previous lesson. File > Open. 

2. Insert the Button Layer 
Insert > Layer. Give it the name “Button”. Click on the “Eye” column to Hide the Graphic Layer. (A red X should 
appear and the artwork and Symbols you’ve been working with on the Graphic Layer will disappear. You don’t need 
to Lock the Layer, because without the Symbols visible, they can’t be edited. If you wanted them visible, but not 
editable/changeable, then you would Lock the Layer.) 

3. Background on Buttons 
Buttons are actually four-frame interactive movie clips. When you select the Button behavior for a Symbol, Flash 
creates a Timeline with four Frames. The first three Frames display the Button's three possible states; the fourth 
Frame defines the active area of the Button. The Timeline doesn't actually play, it simply reacts to pointer 
movement and actions by jumping to the appropriate frame.  
 
To make a Button interactive in a movie, you place an Instance of the Button Symbol on the Stage and assign 
actions to the Instance. The actions must be assigned to the Instance of the Button in the movie, not to Frames in the 
Button's Timeline. 
  
Each frame in the Timeline of a Button Symbol has a specific function:  
 

The first Frame is the Up state, representing the Button whenever the pointer (mouse) is not over the 
Button.  

• 

• 
• 
• 

The second Frame is the Over state, representing the Button's appearance when the pointer is over it.  
The third Frame is the Down state, representing the Button's appearance as it is clicked.  
The fourth Frame is the Hit state, defining the area that will respond to the mouse click. This area is 
invisible in the movie.  

 
What one does with the four states of the Button in the Symbol editing mode is to create the artwork that will be 
displayed in each of the three states that are visible. For example a Button, with a different color for each of the 
states, or a Button that changes its look to have a 3 dimensional effect of being pressed down, or one that changes 
shape. (You have seen many examples of this on the web, even in non-Flash web sites. For example, move the 
cursor along the menu in Flash and see how the menu items change their look to be like a button when the cursor is 
over them.) The shape and size of the artwork for each of the Button states defines the Button’s look, size and 
boundaries (what’s considered on and off the Button) in the Flash movie. 
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4. Create a Button Symbol 
Choose Insert > New Symbol, or press Control+F8. 
 
In the Create New Symbol dialog box, enter a name for the new button symbol, and for Behavior choose Button, 
press OK. 
 
Notice, that Flash switches to Symbol Editing mode (screenshot below). This means that the Stage is showing the 
Symbol Editing for the new Button Symbol that you are creating. All the artwork for Scene1 is still available. At the 
top of the Stage are the menu choices to switch back to Scene1.  
 
To create the button, you convert the button frames to Keyframes. In the Symbol Editing mode, the Timeline shows 
the four states of a Button. Notice that the Frames aren’t numbered, but named for the four states: Up, Over, Down, 
Hit. 
 
Convert the frames to Keyframes. Select the 3 frames that are not yet a Keyframe and press F6 or Insert > Keyframe 
to convert them to Keyframes. They will all have a little circle in them. 
 
 

 

 
 

5. Creating the Artwork for the Four Button States 
In the Timeline, select the Up state. This is the state of the Button when its ready to be pressed (available).  
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[Again, for this exercise, we are not concerned with having fancy artwork, but with demonstrating the methods. For 
your class project, you can make the artwork what you wish. 
 
The artwork can include Text as well. There are several ways of making the text for a Button dynamic, but that is 
beyond the scope of these lessons. For now you will need to either include the text as part of the artwork of the 
Button or overlay the text on top of each specific Instance of the button that you put on the Stage, this latter method 
will be used in these lessons and is useful for creating a Button that can be reused many times, just by putting 
different text on top of each specific Instance.] 
 
First notice in the center of the Symbol Editing Stage that there is a small “plus sign” (+). This is the center of the 
Symbol and the center of the Button, it’s called the “registration point”. In most cases you will want your artwork to 
be centered over this point. 
 
Select the Circle tool. Select two different colors in the Color Mixer and draw a Circle over the registration point 
(the little plus sign ‘+’) of the Symbol in the center of the Stage. 
 
You can use Modify > Align > Center Vertical and Modify > Align > Center Horizontal to have Flash put the 
artwork exactly in the center. 
 
Now select the Over state in the Timeline. Notice that the Stage is blank (there is no artwork). You can create very 
different artwork for each Button state or the same artwork with only simple changes in color or size. 
 
“Copy and Paste” is the easiest method of creating similar artwork for each state. 
 
Select the Up state again and using the Selection tool (the solid arrow in the upper left corner of the toolbar) draw a 
box completely around the artwork (circle) you created and then press Ctrl+C or Edit > Copy to copy it.  
 
Then, select the Over state in the Timeline and press Ctrl+V or Edit > Paste to paste a copy of the artwork into this 
state. 
 
We are going to change the color and size of the Over state artwork, so the User will know when the mouse is over 
the Button. Make sure that you have the artwork selected, it will have a white dot speckled pattern to it, when 
selected. 
 
In the Properties window, select a different Fill color, the color box next to the Paint Can, perhaps one that is a few 
shades lighter or darker than your original color. You can also select a different color for the Stroke, the color box 
next to the pencil. 
 
Next we will make the Button a little bit larger, so that it will visually increase in size when the mouse is over it. 
Select the Arrow Tool and draw a box around the entire circle to select all of it. Then, use the Modify > Transform > 
Scale and Rotate menu option. This brings up a dialog box, which allows you to set the exact amount of the Scale 
increase. It also keeps the artwork centered. (There are several other choices for changing size and shape, but for 
these small incremental changes when keeping the artwork’s center and location is important, this is a good tool 
choice.) Type 105 in the Scale % box (105% - a 5% increase in size) and press OK. 
 
Notice that the artwork grew a little. (Remember, you can use Ctrl+Z or Edit > Undo to undo the change. And, then 
you can use Ctrl+Y or Edit > Redo to redo the change, so you can switch back and forth and see the effects of your 
changes.) 
 
Now, go the Timeline and select the Up state and then Over state and see how the Button artwork will change as the 
mouse moves over it. 
 
Go back to the Over state, select the artwork, and copy it again (as above). Then go to the Down state and paste the 
copy.  
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Now, we will change the shape of the Button. Using the Selection tool, select the artwork. Right click on the artwork 
and select “Envelope” (or Modify > Transform > Envelope from the menu). This puts up an “envelope” (or border) 
around the artwork, by grabbing and dragging any of the black circles you can change the shape of the artwork in 
asymmetric ways. Try it. Change the outlines of the artwork into a shape with a more wavy outline, but not too 
much bigger. (Remember, you can use Ctrl+Z Undo and Ctrl+Y Redo, to go back and forth with your changes.) You 
can, of course, make many other types of changes to the shape using the other drawing tools. 
 
Now, go back to the Up state and select and copy the artwork again. Then go to the Hit State. This state is not a 
visible state. Its purpose is to define the size of the area that Button is active in. That is the size of the area that when 
the mouse moves over it, the Button will switch to the Over state and if the mouse is clicked, it will switch to the 
Down state. Thus, the shape and size of the artwork is important, not its color or fanciness.  
 
Generally, you want the Hit area where the mouse is to be active to be the same size and shape (or slightly bigger) as 
the artwork for the Up state. This is the least confusing for the user. The other main option, if your button is more of 
a circular or non-rectangular shape is to define the Hit area as the smallest rectangle that includes the artwork. This 
means the Button will change to the Over state if the mouse gets into the rectangular area, even if it doesn’t yet 
touch the artwork proper. (You’ve seen this behavior on the web many times, even in non-Flash web pages.) 
 
We will make the size of the Hit area bigger than the Up state. Select the artwork and use Modify > Transform > 
Scale and Rotate menu option and set the Scale % to 120 (20% bigger). Press OK. 
 
Now you’ve finished the artwork for the Button. It may seem like a lot, but once you’ve done it a few times it 
becomes simpler. 

6. Save Your Work 
File > Save 

7. The Library 
Notice that your Button is no longer visible on the Stage or as an option on the Stage menu bar. All Symbols 
including Buttons are stored in the Library. Press F11 or Window > Library to bring up the Library and notice that 
your Button is there. Select the Button. In the upper right corner of the graphic press the little “right arrow” play 
button. Notice that your Button symbol moves through all 4 states. 

8. Enabling, Editing, and Testing Buttons 
By default, Flash keeps Buttons disabled as you create them, to make it easier to select and work with them. When a 
Button is disabled, clicking the Button selects it. When a Button is enabled, it responds to the mouse events that 
you've specified as if the movie were playing. You can still select enabled Buttons, however. In general, it is best to 
disable Buttons as you work, and enable Buttons to test their behavior.  
  
To enable and disable Buttons: 
Choose Control > Enable Simple Buttons. A check mark appears next to the command to indicate Buttons are 
enabled. 
  
Any Buttons on the Stage now respond. As you move the pointer (mouse) over a Button, Flash displays the Over 
frame; when you click within the Button's active area, Flash displays the Down frame.  
  
To select an enabled Button: 
Use the Arrow tool to drag a selection rectangle around the Button.  
 
Choose the command again to disable Buttons, to continue working with them. 

9. Making a Button Link to Another Web Page 
Actions in Buttons apply only to a specific Instance of the Button. This allows you to use the Button artwork again 
and again.  

 
© 2002 ESubjects Inc. All rights reserved. 4



 

 
Select the Button layer. Select your Button in the Library and drag a copy of it onto the Button Layer where you can 
see it (e.g., its not behind another object.) 
 
Open the Properties Window. In the Instance Name field in the upper left corner, which is right below the drop 
down list where you choose the symbol type, give this Instance of the Button a specific name like “Dialect Button”.  
 
Since we created a Button with no text label, we will add that at this time, as well. Select the Text Tool. Move the 
cursor over the Button artwork on the Stage and type the title of the Button: “Dialect”. In the Properties window, 
select the font color and size and perhaps bold face to make it stand out against the Button color (i.e. Light text on a 
dark background, dark text on a light background, etc.) Using the Selection tool move the text so its centered on the 
Button. 
 
Remember: By separating the Text from the Button art the button art can be used again and again (e.g., to make a 
series of buttons that look the same.) If you put the text in with the artwork, you have to make a new symbol each 
time you want different text, thus defeating the point of Symbols and the reuse of art. 
 

10. Adding the Jump to URL 
In order to add the functionality to jump to a URL (i.e. a web page) we will use some simple Action Script. Action 
Script is a language similar to Java Script that is used by Flash to provide programmatic control. It is a large topic in 
its own right and these lessons will not discuss it. 
 
What we will do here is tell you exactly what to do to make a Button jump to a URL. 
 
Choose Window > Actions to display the Actions panel if it's not already visible. If the Actions panel is not in 
normal mode, choose Normal Mode from the View Options pop-up menu which is the little white icon on the top 
right side of the Actions panel. 
 
1) In the top of the Actions Panel is a drop down list. It is important to make sure that the Action Script you are 
creating is associated with the correct Button and not the Layer or another object on the Stage. Open the drop down 
list. You will see two items in it: 

Actions for Frame 1 of Layer Name Button • 
• Actions for Dialect Button (Button) 

 
Select the second one which is a Button – the “(Button)” tells you that this is for the Button named “NASA Button” 
which is the name we gave to this Instance of the Button. 
 
2) In the Actions toolbox, click the Actions category, then click the Browser/Network category, and double-click the 
getURL action. 
 
3) In the Parameters Pane, which popped-up, enter the URL from which to get the document or to which you are 
sending data, following these guidelines: 

Use either a relative path, such as mypage.html, or an absolute path, such as 
http://www.mydomain.com/mypage.html. 

• 

• A relative path lets you describe one file's location in relation to another; it tells Flash to move up and down 
the hierarchy of nested files and folders, starting from the file where you issued the getURL instruction. An 
absolute path is the complete address that specifies the name of the server on which the file resides, the 
path (the nested hierarchy of directories, volumes, folders, and so on), and the name of the file itself. 

 
You would use a relative path to jump to a different page in the same website that the Flash movie is running. You 
would use an absolute path to jump to a web page at a completely different site. 
 
For this example we will jump to the one of the language-related websites discussed in yesterday’s lesson, such as 
the following: 
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http://www.tvsian.com/hubert/article.php?sid=1 (A history of the popular culture expression “All Your Base 
Are Belong to Us”) 
http://www.geocities.com/Broadway/1906/dialects.html (Dialect map of American Regional English) 
 http://www.pittsburghese.com/ (Pittsburgh Dialect) 
http://www.iuo.it/cilaweb/sitocila/lingue/inglese/indirizzario/varietiesofenglish/asian/asian.html (Asian 
Englishes) 
http://www.sierra-leone.org/proverbs.html (Proverbs and Stories in Krio dialect) 

 
Type that in the URL parameter field, notice that the full URL including the “http://” is required. 
  
4) For Window, specify the window or HTML frame into which the document will be loaded, as follows. 
Choose from the following reserved target names:  
 _self specifies the current frame in the current window.  
 _blank specifies a new window.  
 _parent specifies the parent of the current frame.  
 _top specifies the top-level frame in the current window.  
  or enter the name of a specific window or frame as it is named in the HTML file.  
 
For this example we will have the web page show up in a new window, so select _blank from the drop down list. 
 
5) For Variables, leave the default of “Don’t Send”. We won’t be using this parameter for these lessons. 
 
6) Close the Actions Panel by clicking on the down arrow on the upper left corner of the Pane. 

11.  Test the Button 
Referring to Section 9 above make sure that Control > Enable Simple Buttons is “checked” (i.e. turned on.) 
 
Then use Control > Test Movie which will play the Flash Movie. Since we have only a one Frame movie you will 
see all the artwork on both Layers show up. Click on the Dialect Button. The page for their website will show up in 
a Browser window. 
 
Also, move the cursor around your button to see that the hit area is actually bigger than the button artwork, that its 
defined the way you meant it to be. If you need to enlarge the hit area, follow the instructions at the end of section 5. 
 
Congratulations! Your Flash movie can link to other sites. 

http://www.tvsian.com/hubert/article.php?sid=1
http://www.geocities.com/Broadway/1906/dialects.html
http://www.iuo.it/cilaweb/sitocila/lingue/inglese/indirizzario/varietiesofenglish/asian/asian.html
http://www.sierra-leone.org/proverbs.html
http:///

